Este plugin no se ha probado con las últimas 3 versiones mayores de WordPress. Puede que ya no tenga soporte ni lo mantenga nadie, o puede que tenga problemas de compatibilidad cuando se usa con las versiones más recientes de WordPress.

WooCommerce Pedido Mínimo

Descripción

Defina um valor mínimo ou quantidade mínima de itens para permitir a finalização de pedidos no WooCommerce.

Caso o cliente tente finalizar a compra sem atingir o valor mínimo ou quantidade mínima de itens, será exibida mensagem informando o valor/quantidade mínimo(a), o valor/item(ns) total do pedido e o valor/item(ns) necessário(s) para atingir o mínimo configurado para a loja.
O plugin também permite selecionar uma função de usuário do WordPress para aplicar as regras do plugin.

  • É necessário que o WooCommerce esteja instalado e ativo para utilizar este plugin.

The plugin has translations for:

  • Portuguese (Brazil)
  • English
  • Spanish (Spain, Argentina and Colombia)

Description: Plugin to set minimum value for order checkout in WooCommerce.

Descripción: Plugin para establecer el valor mínimo para el pago del pedido en WooCommerce.

Capturas

  • Tela de configuração do plugin.

  • Exemplo de pedido mínimo por valor.

  • Exemplo de pedido mínimo por quantidade.

Instalación

Instalação do plugin:

  • Faça o upload da pasta wc-pedido-minimo para a pasta de plugins ou instale diretamente através da sua instalação do WordPress .
  • Ative o plugin.

Configuração do plugin:

  • Acesse WooCommerce->Configurações e acesse a guia «WC Pedido Mínimo».

  • Acesse «WooCommerce->Configurações» e clique na guia «WC Pedido Mínimo».

  • Ative o plugin.

  • Selecione se vai utilizar o funcionamento por valor ou quantidade.

  • Preencha o campo com o valor ou quantidade mínima desejada.

  • O plugin pode ser aplicado a uma determinada função de usuário do WordPress. Se for o caso, selecione um ou deixe em «Nenhuma Função».

  • Clique em «Salvar Alterações».

Preguntas frecuentes

Qual é a licença do plugin?

Este plugin possui licença GPL.

Quais os requisitos necessários para utilizar o plugin?

  • WooCommerce 3.0 ou posterior.

O plugin leva em consideração o valor do frete?

  • Não. O cálculo só leva em consideração os produtos inseridos no carrinho de compras.

Reseñas

1 de mayo de 2021
Complite destroy my checkout. Cust me days to discover that was it to block the checkout.
5 de enero de 2021
Muy bueno pero sale un warning: Warning: Undefined array key "bacs" in C:\xampp\htdocs\tacosmtyperu\wp-content\plugins\wc-pedido-minimo\inc\load-admin-settings.php on line 170
9 de mayo de 2020
`<?php add_action( 'woocommerce_check_cart_items', 'wc_pedido_minimo_function' ); function wc_pedido_minimo_function() { $pedido_minimo_onoff = get_option( 'wc-pedido-minimo-onoff', false ); $wc_pedido_minimo_get_current_role = wc_pedido_minimo_get_current_role(); $pedido_minimo_usuarios = get_option( 'wc-pedido-minimo-usuarios', false ); if( (is_cart() || is_checkout()) && $pedido_minimo_onoff == 'yes' && ($pedido_minimo_usuarios == '' || $pedido_minimo_usuarios == $wc_pedido_minimo_get_current_role) ) { global $woocommerce; $total_carrinho_valor = WC()->cart->subtotal; $total_carrito_cantidad = WC()->cart->get_cart_contents_count(); $pedido_minimo_funcionamento = get_option( 'wc-pedido-minimo-funcionamento', false ); $pedido_minimo_valor = get_option( 'wc-pedido-minimo-valor', false ); $pedido_minimo_quantidade = get_option( 'wc-pedido-minimo-cantidad', false ); if( $pedido_minimo_funcionamento == 'valor' ) { if( $total_carrito_valor < $pedido_minimo_valor ) { $saldo = wc_price($pedido_minimo_valor - $total_carrito_valor); $mensagem = '<p>'.esc_html__( 'Necesita comprar %s más para alcanzar el valor mínimo de la tienda.', 'wc-pedido-minimo').'</p></div>'; if ( $total_carrito_valor !== 0 ) { $simbolo_moeda = get_woocommerce_currency_symbol(); wc_add_notice( sprintf( '<div class="alerta_pedido_minimo"><p>'.esc_html__('O Pedido debe tener o valor mínimo de', 'wc-pedido-minimo').' <strong>'.$simbolo_moeda.' %s</strong>.</p>'.'<p>'.esc_html__('O Valor total de su pedido ahora es de', 'wc-pedido-minimo').' <strong> %s</strong>.</p>'.$mensagem, wc_price($pedido_minimo_valor), wc_price($total_carrito_valor), $saldo ), 'error' ); } } } elseif( $pedido_minimo_funcionamento == 'cantidad' ) { if( $total_carrito_cantidad < $pedido_minimo_cantidad ) { $saldo = $pedido_minimo_cantidad - $total_carrito_cantidad; if ( $saldo == 1 ) { $txtItem = 'item'; } elseif ($saldo > 1) { $txtItem = 'itens'; } $mensagem = '<p>'.esc_html__( 'Necesita comprar %s '.$txtItem.' para alcanzar el valor mínimo de la tienda.', 'wc-pedido-minimo').'</p></div>'; if ( $total_carrito_cantidad !== 0 ) { if ( $total_carrito_cantidad== 1 ) { $txtItem = 'item'; } else { $txtItem = 'itens'; } wc_add_notice( sprintf( '<div class="alerta_pedido_minimo"> <p>'.esc_html__('O Pedido debe tener la cantidad mínima de', 'wc-pedido-minimo').' <strong>%s itens</strong>.</p>'.'<p>'.esc_html__('Su pedido ahora propio', 'wc-pedido-minimo').' <strong> %s '.$txtItem.'</strong>.</p>'.$mensagem, $pedido_minimo_quantidade, $total_carrito_quantidade, $saldo ), 'error' ); } } } } } function wc_pedido_minimo_get_current_role() { if( is_user_logged_in() ) { $user = wp_get_current_user(); $role = ( array ) $user->roles; return $role[0]; } else { return false; } }
Leer todas las 9 reseñas

Colaboradores y desarrolladores

«WooCommerce Pedido Mínimo» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

«WooCommerce Pedido Mínimo» ha sido traducido a 1 idioma local. Gracias a los traductores por sus contribuciones.

Traduce «WooCommerce Pedido Mínimo» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

1.0.0 – 2018/01/09

  • Lançamento do plugin.

1.2.0 – 2018/01/14

  • Tradução Português/Inglês.
  • Alteração no preenchimento do campo de valor no admin. Agora sem máscara e sem símbolo de moeda, utilizando mesmo padrão do campo de valores (como preço de produtos) no WooCommerce.
  • A formatação de preços e símbolo da moeda serão exibidos de acordo com o padrão configurado na loja.

1.2.1 – 2018/08/11

  • Tradução Espanhol.
  • Correção da condição para pedido mínimo em load-pedido-minimo.php.

2.0.0 – 2018/11/23

  • Opção para ativar/desativar plugin diretamente na tela de configuração.
  • Seleção de valor mínimo ou quantidade mínima de itens no pedido.
  • Possibilidade de escolher uma função de usuário para a regra (valor/quantidade) ser aplicada.

2.0.1 – 2018/11/23

  • Correção dos arquivos de tradução e textos em espanhol.

2.0.2 – 2019/10/01

  • Ajuste para que o CSS personalizado do plugin não interfira em outras páginas de configurações do Woocommerce.
    Contribuição do @myst1010

2.0.3 – 2020/06/27

  • Ajustes nas traduções para espanhol e inglês.
  • Termos das opções do painel administrativo adicionados na tradução

2.0.4 – 2020/06/29

  • Ajustes no caminho para as traduções.

2.1.0

  • Adicionada a função de selecionar método de pagamento requerido para finalização do pedido.
    É uma regra adicional que é validada na etapa de Checkout.