Simple Accessible Spoilers

Descripción

Create fully accessible content spoilers or accordions with a shortcode.

  1. Fully accessible to screen reader users
  2. Creates a flexible spoiler shortcode
  3. Define groups of accordions to close open accordions when another in the same group is opened.
  4. Override design in theme CSS files

Sample Code

[spoiler title="Sample Code" initial_state="expanded" tag="h2" group="a"]
Include content here
[/spoiler]

Attributes

title: should include the clickable text to be displayed in your accordion
initial_state: values include collapsed or expanded, default to «collapsed»
group: any alphanumeric value. used to define a group of accordions. when one accordion is opened all other items in the group will be closed.
tag: values include any typical html tag but a heading tag should be used for accessibility, defaults to H2

Instalación

  1. Install via WordPress Dashboard or upload simple-accessible-spoilers.zip;
  2. Activate the plugin through the ‘Plugins’ menu in WordPress;
  3. Use «spoiler» shortcode in your content;

Preguntas frecuentes

How can I customize design of the spoiler?

Override the styles found in styles/simple-accessible-spoilers-styles.css in your theme css files

Reseñas

Leer la 1 reseña

Colaboradores y desarrolladores

«Simple Accessible Spoilers» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

Traduce «Simple Accessible Spoilers» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

1.0.9

  1. corrected spoiler titles being stripped when certain accented characters exists in the title

1.0.8

  1. added option to customize shortcode

1.0.7

  1. changed spoiler toggle role to link to correct validation issue

1.0.6

  1. Added attribute input validation

1.0.5

  1. Added option to group accordions so that opening a new accordion will close opened items in the same list.

1.0.4

  1. WordPress 5.5 Compatibility release

1.0.3

  1. corrected bug resulting in initial state not displaying correctly

1.0.2

  1. corrected php not object error when post object is not found in a page
  2. added jquery dependency to wp_register_script to correct jquery not being loaded in some themes

1.0.1

  1. corrected bug with scripts not enqueue as expected
  2. added dashboard messages