Este plugin no se ha probado con las últimas 3 versiones mayores de WordPress. Puede que ya no tenga soporte ni lo mantenga nadie, o puede que tenga problemas de compatibilidad cuando se usa con las versiones más recientes de WordPress.

mqtranslate langcode widget selector

Descripción

Extension of the mqtranslate plugin that creates a widget that displays a language selector with language codes. For example, if you have got a site in 3 different
languages (Deutsch, english, spanish), the widget will display: de | en | es

The plugin is compatible with Qtrasnlate Slug {qts}.

It also has got the following filters:

  • ‘lang-code-selector-content’ => This filter allows alter the content of each idiom.

Arbitrary section

Instalación

  • Install plugin either via the WordPress.org plugin directory, or by uploading the files to your server.
  • Activate the module.

Preguntas frecuentes

How can i change the content of the switcher?

Yes. It’s posible change the content of the selector. You only have to add a filter in the functions.php in your theme or add the code in yoyr custom plugin.

For example:

add_filter( ‘lang-code-selector-content’, ‘test_lang_code_selector_content’ );

function test_lang_code_selector_content( $lang_code ){
global $q_config;
$link_flag_url = dirname(plugins_url()) . ‘/’ . $q_config[‘flag_location’] . $q_config[‘flag’][$lang_code];
$link_flag = «»;
return $lang_code . $link_flag ;
}

How do i contribute to this plugin?

I’ve open a project in my github profile. Feel free to fork and change the code.

Colaboradores y desarrolladores

«mqtranslate langcode widget selector» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

Registro de cambios

1.0

  • Compatibylity with qransalte slug
  • Added filter: ‘lang-code-selector-content’
  • Realeased plugin.