Helper Lite for PageSpeed

Descripción

Acelera tu sitio con los atributos decoding=»async» y loading=»lazy» para <img> y <iframe>. Elimina el problema «No usa oyentes pasivos para mejorar el rendimiento del desplazamiento». Ayuda a mejorar tu puntaje de Google PageSpeed ​​Insights.
El desarrollo principal está en GitHub.

Translations

Help translate Helper Lite for PageSpeed

Capturas

  • Antes de activar el plugin
  • Después de activar el plugin
  • Tab Setting on Plugin Settings Page
  • Tab Script on Plugin Settings Page

Instalación

Desde el escritorio de WordPress

  1. Visita «Plugins > Añadir nuevo»
  2. Busca «Helper Lite for PageSpeed»
  3. Activa Helper Lite for PageSpeed desde tu página de plugins.
  4. [Opcional] Configura el plugin en «WP Booster > PageSpeed Helper».

Desde WordPress.org

  1. Descarga Helper Lite for PageSpeed.
  2. Sube el directorio «helper-lite-for-pagespeed» al directorio «wp-content/plugins/», usando tu método favorito (ftp, sftp, scp, etc…)
  3. Activa Helper Lite for PageSpeed desde tu página de plugins.
  4. [Opcional] Configura el plugin en «WP Booster > PageSpeed Helper».

Preguntas frecuentes

¿Qué hace el plugin?

  • Añade los atributos decoding=»async» y loading=»lazy» a todas las imágenes de la página. Se ha demostrado experimentalmente que la combinación de estos atributos acelera la carga de la página entre 0,1 y 0,2 segundos y aumenta la puntuación de Google PageSpeed ​​Insights.
  • Añade los atributos loading=»lazy» a todos los <iframe> en la página.
  • Puedes incluir un script que elimine el comentario de Google PageSpeed ​​Insights «No utiliza oyentes pasivos para mejorar el rendimiento del desplazamiento».

In WordPress 5.5 and up, images are lazy loaded by default. Why is this plugin needed?

By default, WordPress add a loading=»lazy» attribute to the following images:
* images within post content
* images within post excerpts
* images within text widgets
* avatar images
* template images using wp_get_attachment_image() (wp_get_attachment_image)
But WordPress does not add loading=»lazy» for custom images in the header and footer of the site! In this case, our plugin will help you.

¿Dónde están los ajustes del plugin?

Los ajustes se encuentran en la sección del panel de administración «WP Booster > PageSpeed ​​Helper»

¿Cómo lo configuro?

  1. En la primera pestaña, «Ajustes», puedes elegir cómo añadir los atributos.
  • The first method ‘Filters’ is safe, but does not apply attributes to all images.
  • The second method ‘Buffer’ will add attributes to all images, but may cause problems on some sites.
  • You can choose what values set to attributes or turn off them at all.
  1. At the second tab ‘Scripts’ you can turn on a script,
    which removes the Google PageSpeed Insights remark “Does not use passive listeners to improve scrolling performance”.

¿Qué significa «No utiliza oyentes pasivos para mejorar el rendimiento del desplazamiento»?

Esta nota de PSI, por ejemplo, puede aparecer en las páginas donde se carga el script comment-reply.min.js. Otros scripts también pueden llevar a este comentario.

Instalé el plugin, pero mi puntuación de Google PageSpeed ​​Insights no aumentó

  • Vacia la caché en tu sitio
  • El efecto máximo estará en la página con imágenes. Sin imágenes, no hay resultado
  • El plugin no afecta a las imágenes añadidas al fondo mediante CSS, por la sencilla razón de que es imposible añadirles los atributos `decoding=»async»` y `loading=»lazy»`. El plugin solo funciona con imágenes añadidas a través de la etiqueta <img>.

Disabling LazyLoad on Specific Images

If you want to disable LazyLoad on a specific image, you can do so by adding the skip-lazy class to the <img> HTML tag.

Reseñas

6 de noviembre de 2020
A simple solution to a persistent problem!
21 de julio de 2020
Поможет ускорить сайт при открытии последних версиях Хром и ему подобных. Разработчикам посоветую добавить комментарии к настройкам.
20 de julio de 2020
Намного улучшились показатели сайта. На мобильном 25-->41 компьютер 61-->87 The site's performance has improved a lot. On mobile 25 -> 41 computer 61 -> 87
Leer todas las 7 reseñas

Colaboradores y desarrolladores

«Helper Lite for PageSpeed» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

«Helper Lite for PageSpeed» ha sido traducido a 5 idiomas locales. Gracias a los traductores por sus contribuciones.

Traduce «Helper Lite for PageSpeed» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

3.0.9 (12.02.2021)

  • Added tab with our useful plugins
  • Added support for WordPress 5.6+

3.0.8

  • Updated description
  • Fallos corregidos

3.0.6

  • Updated description

3.0.5

  • Changed Setting page
  • Added disable function for loading lazy in WP 5.5 and higher
  • Added disable function for lazyload on specific images

3.0.4

  • Added «More optimization» tab
  • Deleted support chat link

3.0.3

  • Fallos corregidos

3.0.2

  • Corregido un fallo con las traducciones

3.0.1

  • Fallos corregidos

3.0

  • La estructura del plugin se ha vuelto a escribir completamente
  • Corrige un fallo que añadía dos barras en la URL del script
  • La pestaña «Contacto» cambió a «Ayuda»
  • Añadida una pequeña lista de preguntas frecuentes
  • Añadida más información de contacto

2.5.8

  • Corregida la incompatibilidad con la versión pro del plugin.
  • Corregidos los estándares de código de WordPress
  • Añadido un nuevo ícono y portada

2.5.7

  • Fallos corregidos

2.5.6

  • Añadida compatiblidad con el atributo loading=»lazy» para iframe
  • Añadido «loading para iframe» en la página «Ajustes»

2.5.4

  • El plugin funciona solo con solicitudes GET debido a problemas de Gutenberg
  • El búfer no se limpia después del trabajo del plugin
  • Ahora es posible seleccionar el valor de los atributos o desactivar el atributo en absoluto
  • Añadidos los enlaces «Ajustes» y «Autor» en la página del plugin

2.5.3

  • Se corrigieron las comillas dobles sin sanear en las llamadas AJAX
  • Los eventos pasivos solo se aplican a los eventos «touchstart», «scroll» y «wheel»
  • Se corrigió la advertencia «undefined offset»

2.5.2

  • Corregido el problema «No utiliza oyentes pasivos para mejorar el rendimiento del desplazamiento»
  • Añadida compatibilidad para los idiomas ruso e inglés

2.5.1

  • Corregidos los estándares de código de WordPress

2.3.8 (17.07.2020)

  • Corregidos los estándares de código de WordPress

2.3.7

  • Fallos corregidos

2.3.3

  • Fallos corregidos

2.2

  • Fallos corregidos

2.1

  • Fallos corregidos

2.0 (10.07.2020)

  • Fallos corregidos