DNI WooCommerce

Descripción

¿Qué hace este plugin?
– Muestra un campo en la página de finalizar compra
– Permite añadir el DNI al crear un pedido manual.
– Permite mostrar el DNI en las facturas, correos electrónicos, etc.
– Verifica que hay 8 números y una 1 letra.
– Otros plugins crean un campo adicional, este complemento ha usado _billing_vat_number que ya está integrado en WooCommerce
– Al desactivar o eliminar el plugin, puedes consultar los DNI capturados

Capturas

  • Ejemplo de cómo se muestra al finalizar compra
  • Mensaje de validación

Instalación

  1. Descarga el plugin del repositorio
  2. Activa el plugin desde el menú de WordPress.

Preguntas frecuentes

¿Dónde se almacena el contenido del campo?

Se guarda en _billing_vat_number. Puedes buscarlo en la tabla wp_postmeta

Reseñas

2 de junio de 2020
Error in validation company CIF number. This plugin JUST validate personals NIF. Error on NIE and CIF.
Leer todas las 3 reseñas

Colaboradores y desarrolladores

«DNI WooCommerce» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

«DNI WooCommerce» ha sido traducido a 3 idiomas locales. Gracias a los traductores por sus contribuciones.

Traduce «DNI WooCommerce» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

1.0.9

  • Compatible con WordPress 4.1.0
  • Compatible con WordPress 5.4

1.0.8

  • Compatibilidad para WooCommerce 3.9.0
  • Compatibilidad para WordPress 5.3

1.0.7

  • Compatibilidad con WooCommerce 3.7.0

1.0.6

  • Sistema de validación al editar un pedido

1.0.5

  • Compatibilidad con WooCommerce 3.6.0
  • Compatibilidad con WordPress 5.2

1.0.4

  • Comprobación PHPCS
  • Mejorada la validación
  • Se añadió un mensaje cuando WooCommerce no está activado.

1.0.4

  • Comprobación PHPCS
  • Mejorada la validación
  • Se añadió un mensaje cuando WooCommerce no está activado.

1.0.3

  • Error de traducción
  • Más seguridad

1.0.2

  • Corregido aviso de php
  • Imágenes añadidas

1.0.1

  • Validación de campo simple y correcciones menores.

1.0

  • Versión inicial